GoEasy SDK - 兼容不支持Websocket的浏览器

为了兼容IE6,7,8,9和其他一些不支持Websocket协议的Web浏览器,从2015年起, GoEasy客户端SDK就长期内置了Websocket和Polling两种通讯方式,自动支持不同的客户端使用不同的方式通讯。

时至5年后的2020年,需要兼容IE6,7,8等老版本浏览器的需求已经极少。

为了给绝大多数用户,更好的连接体验,从GoEasy 1.1开始,默认连接方式改为websocket,相比之前的版本,连接性能显著改善。

如果您的项目依然需要支持类似IE6,7,8等不支持websocket的浏览器,也一如既往的容易。

添加一个参数,兼容不支持Websocket的浏览器

强烈建议:除非确认您的应用一定要兼容类似于IE6,7,8,9等古董浏览器,否则不要开启该配置。

只需要在初始化的GoEasy对象时,添加一个supportOldBrowser属性,将值设为true即可。


    <!--[if lte IE 8]>//如果需要支持低版本的IE8及以下
    <script  type="text/javascript" src="https://cdn.goeasy.io/json2.js"></script>
    <![endif]-->    


    var goEasy = new GoEasy({
        host:'hangzhou.goeasy.io', 
        appkey: "my_appkey", 
        supportOldBrowser:true  //默认为false, 设置为true,即可完美兼容IE6,7,8,9等古董浏览器^-^
    });

results matching ""

    No results matching ""